EU & US Sites are operating fine but EU monitoring system is incorrectly reporting issues.

Incident Report for EvolutionX

Resolved

This incident has been resolved.
Posted Oct 06, 2025 - 17:17 UTC

Monitoring

We determined that some of the IP addresses used by our monitor service were caught up in a large update of IPs in our blacklist to protect sites from agressive scraping. We removed the Pingdom addresses from the blacklist and are monitoring the results.
Posted Oct 05, 2025 - 15:30 UTC

Investigating

We have had good up time for all stores but the EU monitoring system is getting blocked and incorrectly reporting downtime. EU and US Sites are operating fine but investigating the monitoring system and why it is reporting issues.
Posted Oct 05, 2025 - 07:15 UTC
This incident affected: EvolutionX EU / UK (Storefront).