DDMS Integration Order Updates

Incident Report for EvolutionX

Resolved

This incident has been resolved.
Posted Jan 16, 2026 - 06:23 EST

Monitoring

An issue with DDMS integration was detected and fixed. There was no impact to the orders sent to DDMS. We are updating the affected orders on EvolutionX. There's no action required from customers and no other integrations have been affected.
Posted Jan 15, 2026 - 13:23 EST
This incident affected: EvolutionX US / CA (Admin).