TIMS Live Pricing failing

Incident Report for EvolutionX

Postmortem

Incident Title: OAuth Token Refresh Failure Impacting Live Pricing on EvolutionX Stores Integrated with TIMS ERP
Incident Dates: August 30–31, 2025
Restoration Date: September 1, 2025  

Incident Summary

During a planned database maintenance window on Saturday, August 30, 2025, the EvolutionX platform experienced a usability issue affecting live pricing functionality for stores integrated with the TIMS ERP system by CU. The issue persisted through Sunday, August 31, and was resolved by Monday, September 1, 2025.

Impact Analysis

Affected Functionality: Live pricing via TIMS ERP integration  

Unaffected Functionality: Checkout, live order history, and other store operations  

Customer Impact: Users were unable to retrieve live pricing data during the outage window, potentially affecting quoting and purchasing decisions.

Root Cause

TIMS ERP requires OAuth 2.0 token refreshes hourly. EvolutionX centrally manages token refreshes and attempts renewal for up to one hour after expiry. During the database update, the EvolutionX database was offline for longer than one hour, exceeding the retry threshold. As a result, expired tokens were not refreshed, and live pricing calls failed.

This behavior is intentional to prevent indefinite retries in cases where access may be revoked or the third-party system is unavailable.

Resolution

The EvolutionX team detected the issue and identified the root cause.

Live pricing functionality was restored by Monday, September 1, 2025.

Preventive Actions

Code Update: The retry threshold for token refresh has been extended from 1 hour to 24 hours to accommodate longer maintenance windows.

Self-Service Enhancement: The ERP self-service app now includes a test button allowing users to manually refresh tokens for live pricing.

Customer Communication Notes

This was not a software bug but a condition encountered during planned maintenance. The system behaved as designed to protect against misuse of expired or invalid tokens. The enhancements made will improve resilience and user control in future scenarios.

Posted Sep 17, 2025 - 22:10 UTC

Resolved

During a planned database maintenance window on Saturday, August 30, 2025, the EvolutionX platform experienced a usability issue affecting live pricing functionality for stores integrated with the TIMS ERP system by CU. The issue persisted through Sunday, August 31, and was resolved by Monday, September 1, 2025. This was not a software bug but a condition encountered during planned maintenance. The system behaved as designed to protect against misuse of expired or invalid tokens. The enhancements made will improve resilience and user control in future scenarios.
Posted Aug 30, 2025 - 05:00 UTC