Elevated Errors in Storefront

Incident Report for EvolutionX

Resolved

This incident has been resolved.
Posted Mar 08, 2026 - 08:26 EDT

Monitoring

Additional resources and blocks are having the required effect, response times for storefronts have returned to normal.
Posted Mar 08, 2026 - 08:06 EDT

Identified

We're experiencing an elevated level of errors in EU/UK region of EvolutionX Storefront hosting. We've identified large volume of scraping from many IPs and are adding resources and blocking rules to respond. Services are returning to normal.
Posted Mar 08, 2026 - 08:01 EDT
This incident affected: EvolutionX EU / UK (Storefront).