Performance Issues in Storefront for EU/UK stores

Incident Report for EvolutionX

Resolved

This incident has been resolved.
Posted Aug 05, 2026 - 10:51 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 05, 2026 - 07:58 EDT

Update

We have identified an issue reading a caching table and resulting in a hot partition. A fix has been identified and is currently being developed. We'll update this issue as we monitor the deployment of the fix and resolution of the hot partition.
Posted Aug 05, 2026 - 06:09 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 05, 2026 - 06:04 EDT

Investigating

We're experiencing an performance issues in EvolutionX Storefront for EU/UK stores and are currently looking into the issue.
Posted Aug 05, 2026 - 05:41 EDT
This incident affected: EvolutionX EU / UK (Storefront).