Invoice Payments Error

Incident Report for EvolutionX

Postmortem

Incident Title: Invoice Payments Error on.
Incident Dates: September 25, 2025 06:50 AM EST
Restoration Date: September 25, 2025 1:35 PM UTC
Affected System: Invoice Payments feature on ERP-integrated EvolutionX stores

Incident Summary
On September 25th, 2025, storefront users were affected by an error in the Invoice Payments feature. The root cause was a missing default value for a new required attribute, introduced during a recent update. The issue was resolved by deploying a fix at 9:45 AM EST. We regret the impact and are reviewing our deployment process to prevent recurrence.

Impact Analysis
Customer Impact:
• 59 storefront users affected from 06:50 AM EST until 9:45 AM EST.
• Users attempting to pay invoices were redirected to the payment page but encountered a 500 Error.
• All stores with ERP-integrated Invoice Payments were impacted.
Unaffected Functionality: Storefront, Pricing, Checkout, live order history, and other store operations.

Root Cause
A code deployment intended to resolve a feature issue introduced a new required attribute on the Invoice Pay screen, but lacked default handling to ensure it had a value if not explicitly set. Any customer attempting to pay an outstanding invoice was affected.

Resolution
• Issue identified via customer reports.
• Fix deployed at 9:45 AM EST, fully restoring payment functionality.

Preventive Actions
Team communication error during deployment: planned additional tests were not carried out.

Prevention:
• Written deployment plan agreed as part of PR review.
• Specific tests added to cover existing functionality.

Posted Sep 25, 2025 - 23:24 UTC

Resolved

On September 25th, 2025, 59 storefront users were known to be affected by an error in the Invoice Payments feature. Users attempting to pay invoices were redirected to the payment page but encountered a 500 Error. This issue impacted all stores with an ERP-integrated Invoice Payments option. The root cause was a missing default value for a new required attribute on the Invoice Pay screen, introduced during a recent update. We were notified by customers of the issue and a fix was deployed at 9:45 AM EST, fully restoring payment functionality for all affected users. We regret the impact on users and we are reviewing the deployment process used and we are adding this example to our testing routine.
Posted Sep 25, 2025 - 18:24 UTC
This incident affected: EvolutionX US / CA (Storefront).