Elevated Errors Affecting EvolutionX Storefronts in the EU and UK

Incident Report for EvolutionX

Resolved

We have deployed a fix and disabled the trending search feature while we review the resources needed for this feature.
Posted Jul 29, 2026 - 08:36 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 29, 2026 - 07:49 EDT

Update

We are continuing to investigate this issue.
Posted Jul 29, 2026 - 07:27 EDT

Investigating

We are currently experiencing an elevated level of errors affecting some EvolutionX storefronts in the EU and UK region.

Customers may experience intermittent issues with storefront browsing, search functionality, and page load performance.

Our team has identified the affected services and is actively investigating the root cause while working to stabilize the environment.

We will provide further updates as more information becomes available.
Posted Jul 29, 2026 - 06:30 EDT
This incident affected: EvolutionX EU / UK (Storefront).