Email sending impacted in the US Region.

Incident Report for EvolutionX

Resolved

This incident has been resolved.
Posted Nov 19, 2025 - 12:58 EST

Update

All emails in the backlog have been completed.
Posted Nov 19, 2025 - 12:05 EST

Monitoring

Email sending was impacted in the US region. A fix was deployed at 11:14am EST and sending the backlog of emails should be completed by no later than 12pm EST.
Posted Nov 19, 2025 - 11:51 EST
This incident affected: EvolutionX US / CA (Storefront, Admin).