Elevated Errors in Storefront

Incident Report for EvolutionX

Update

All stores are now working and we are continuing to add resources and resolve the issues with search that caused the load issues. Stores are all using legacy search while this is in progress.
Posted May 28, 2026 - 09:20 EDT

Identified

The issue has been identified and a fix is being implemented. The issues is effecting some US stores and more resources are being added.
Posted May 28, 2026 - 09:11 EDT

Update

We are continuing to investigate this issue.
Posted May 28, 2026 - 09:08 EDT

Investigating

We're experiencing an elevated level of errors in EvolutionX Storefront and are currently looking into the issue.
Posted May 28, 2026 - 09:07 EDT
This incident affects: EvolutionX US / CA (Storefront).