Elevated Errors in Storefront

Incident Report for EvolutionX

Resolved

This incident has been resolved.
Posted Nov 21, 2025 - 15:23 EST

Monitoring

We're experiencing an elevated level of errors in Ireland UK hosted EvolutionX Storefronts at about 7am. Automated and manual steps were taken which returned sites to stable performance and we continue to monitor it.
Posted Nov 21, 2025 - 03:50 EST
This incident affected: EvolutionX EU / UK (Storefront).